©2003 Kåre Sjölander and Jonas Beskow
Introduction Download Documentation Links Forum
WaveSurfer user forum

FAQ  FAQ
Search  Search
Memberlist  Memberlist
Register  Register
Profile  Profile
Login  Login

using QuickTime movie on Mac OS X

 
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer
View previous topic :: View next topic  
Author Message
ev



Joined: 12 Nov 2003
Posts: 1
Location: Shiga, Japan

PostPosted: Wed Nov 12, 2003 3:38 am    Post subject: using QuickTime movie on Mac OS X Reply with quote

I use wavesurfur for analyzing QuickTIme movie.
The interface is great and fast, but I have one trouble.
Everytime I play after selecting a large range (around 0.7-1.0s?) on a pane,
I get the alert of Wavesurfer internal error "integer value too large to represent".
Does anyone know the solution?

I use Mac OS 10.3, installed TclTkAquaBI and Wavesurfer 1.5.6,
and video plug-in. The error log is as bellow.

--------------------------------------
integer value too large to represent
while executing
"expr {int($fraction*[$s cget -rate])}"
("Play" arm line 3)
invoked from within
"switch -- $message {
"Converting rate" {
set message [::util::mc "Converting sample rate..."]
}
"Converting encoding" {
set message [::uti..."
(procedure "progressCallback2" line 2)
invoked from within
"progressCallback2 .x2.bf.lab Play 1.81784004448e+12"
("eval" body line 1)
invoked from within
"eval progressCallback2 $name $args"
(procedure "pgcb.x2" line 3)
invoked from within
"$d(playpositionProc) Play $curpos"
(procedure "_updatePlayMarker" line 69)
invoked from within
"_updatePlayMarker .x2.s2"
(in namespace inscope "::wsurf" script line 1)
invoked from within
"::namespace inscope ::wsurf {_updatePlayMarker .x2.s2}"
("after" script)
--------------------------------------
Back to top
View users profile Send private message Visit posters website
beskow
Site Admin


Joined: 14 Aug 2002
Posts: 39
Location: KTH, Centre for Speech Technology

PostPosted: Tue Nov 18, 2003 11:55 am    Post subject: Reply with quote

I was unable to reproduce this problem on our mac (OSX 10.2.6). Perhaps you could send the smallest file you can find that reproduces the problem, along with information about configuration used and exact instructions for reproduction of the error, then we will have a look at this.

regards
-Jonas
Back to top
View users profile Send private message Visit posters website
Display posts from previous:   
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.1 © 2001, 2002 phpBB Group