©2003 Kåre Sjölander and Jonas Beskow
Introduction Download Documentation Links Forum
WaveSurfer user forum

FAQ  FAQ
Search  Search
Memberlist  Memberlist
Register  Register
Profile  Profile
Login  Login

Pitch Contour Causes Choppiness?

 
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer
View previous topic :: View next topic  
Author Message
rgaimari



Joined: 12 Mar 2004
Posts: 2

PostPosted: Wed Mar 17, 2004 9:58 pm    Post subject: Pitch Contour Causes Choppiness? Reply with quote

Hi,

Sorry if this question has been asked before; I looked and didn't see anything too similar. I'm using WaveSurfer version 1.6.2 on Windows 2000.

I load a large wav file (~40 Meg), display the waveform, and create a pitch contour pane (with all of the default values). When I play the sound file, the playback and pane scrolling "stutters", pausing every 1/2 second or so. I found, by playing around with some of the default values for the pitch contour pane, that if I change the value of Frame interval from the default (0.01 s) to a higher value, the stutter is less pronounced. At Frame interval 0.05 s, it is not noticeable at all. However, when I do the playback, the sound and the pane scrolling slowly goes out of sync; at Frame interval 0.05 s, it takes about 45 seconds or so to become noticeable.

Any ideas on removing this stutter? If you need more information than I've given here, please let me know. Thanks.

- Bob Gaimari
Back to top
View users profile Send private message
kare



Joined: 16 Aug 2002
Posts: 371
Location: KTH, Centre for Speech Technology

PostPosted: Thu Mar 18, 2004 4:19 pm    Post subject: Reply with quote

You've probably found a bug (the out-of-synch issue)
The stuttering is probably because there more graphics drawn than WaveSurfer can handle. You could try setting Properties | Data Plot | Plot column ... Line in order to make things faster.

Kåre
Back to top
View users profile Send private message Visit posters website
rgaimari



Joined: 12 Mar 2004
Posts: 2

PostPosted: Thu Mar 18, 2004 5:26 pm    Post subject: Reply with quote

Changing the Data Plot from Dots to Line gave a significant improvement, even with the Frame interval set at 0.01 s. The sound and display still go slightly out of sync, but it's not noticeable for 15-18 minutes. I accidentally found that if I pause and then unpause the playback, that is enough to get them right back into sync. Thanks very much for your help.

- Bob
Back to top
View users profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.1 © 2001, 2002 phpBB Group