©2003 Kåre Sjölander and Jonas Beskow
Introduction Download Documentation Links Forum
WaveSurfer user forum

FAQ  FAQ
Search  Search
Memberlist  Memberlist
Register  Register
Profile  Profile
Login  Login

trying to run wavesurfer.tcl - "package require tkcon&q

 
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer
View previous topic :: View next topic  
Author Message
rwd



Joined: 01 Apr 2004
Posts: 1

PostPosted: Thu Apr 01, 2004 5:02 pm    Post subject: trying to run wavesurfer.tcl - "package require tkcon&q Reply with quote

Hello. I am on Win XP (SP1), with tclPro 1.4. The binary version of wavesurfer runs fine. Trying to run the source version from a DOS window, I get the above error. I have found the tkcon.tcl file from a google search, but this does not solve the problem. If it is a package, I expected to find a tkcon.dll somewhere. I am not fluent in tcl/tk so I expect there is a simple answer - but what is it please?


Richard Dobson
Back to top
View users profile Send private message Send email
Geoffrey



Joined: 03 Feb 2003
Posts: 32
Location: Belgium

PostPosted: Fri Apr 02, 2004 8:32 am    Post subject: Reply with quote

tkcon is apparently a standalone package, including no dll.
There is something strange: if you downloaded the source distribution, you should have tkcon.tcl present and at the right place, i.e. in the same directory as other packages (wsurf1.6 normally).
Now, after downloading it, you must put the file in a directory checked by Tcl. You might place it in the wsurf1.6 directory, where it should normally be, or set (update) your TCLLIBPATH environment variable, for the directory your file is in to be checked.
Be careful that TCLLIBPATH uses a special format, where white space is a separator. You must then escape white spaces inside pathes and escape other special characters such as backslashes.
Do not hesitate to contact me by email if you need more help:
geoffrey DOT wilfart AT tcts DOT fpms DOT ac DOT be

Regards,
Geoffrey
Back to top
View users profile Send private message
Guest






PostPosted: Sun Apr 04, 2004 12:33 pm    Post subject: Re: trying to run wavesurfer.tcl - "package require tkc Reply with quote

Thanks. I hage solved the problem by the brute-force method of upgrading to tcl/tk 8.4.5 - that includes the tkcon package. I now have Wavesufer running from the source distribution, and have now tweaked snack to render multi-channel files properly. There may be a Wavesufer issue here about correct handling of audio devices on Windows, but it is firstly a snack issue. May follow up later on, on a new thread.

Richard Dobson
Back to top
kare



Joined: 16 Aug 2002
Posts: 371
Location: KTH, Centre for Speech Technology

PostPosted: Mon Apr 05, 2004 8:32 pm    Post subject: Reply with quote

tkcon.tcl is contained in the distribution, maybe something's gone wrong somewhere. Will check it out when I get back in the office next week.
But since it seems to work fine with Tcl/Tk 8.4.5 I guess it just proves that it's always worth upgrading as often as possible, which also applies to WaveSurfer itself icon_wink.gif

Kåre
Back to top
View users profile Send private message Visit posters website
Display posts from previous:   
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.1 © 2001, 2002 phpBB Group