©2003 Kåre Sjölander and Jonas Beskow
Introduction Download Documentation Links Forum
WaveSurfer user forum

FAQ  FAQ
Search  Search
Memberlist  Memberlist
Register  Register
Profile  Profile
Login  Login

Lin24Packed not handled properly

 
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer
View previous topic :: View next topic  
Author Message
martial



Joined: 23 Nov 2004
Posts: 4

PostPosted: Tue Nov 23, 2004 2:00 am    Post subject: Lin24Packed not handled properly Reply with quote

Hello,

I am using wavesurfer 1.7.4 and I encounter a strange issue when opening the file stored at:
[url]http://www.asliceof.net/tmp_files/22050_Lin24Packed_Mono_Motorola.raw[/url]

The file is: 22050Hz, Lin24Packed, Mono, and Motorola byte order and about 2 minutes longs.

wavesurfer shows nothing (max and value are 0 line) for the content of the file when I select Lin24Packed.

When selecting Lin24 it does show something, but the file length is now 1min30 instead of 2min.

Obviously, there are some problem since that data is a succession of 24bit data _not_ 24bit put in a 32bit container.

This bug has been around for a little while and was corrected in earlier versions of the program (1.5.X ... just whish I could remember which X it was). It is surprising to see it rehappen all of a sudden.

Sincerely,

-- Martial MICHEL
Back to top
View users profile Send private message
kare



Joined: 16 Aug 2002
Posts: 371
Location: KTH, Centre for Speech Technology

PostPosted: Tue Nov 23, 2004 3:24 pm    Post subject: Reply with quote

Thanks for the report! I'll look into this.

Kåre
Back to top
View users profile Send private message Visit posters website
kare



Joined: 16 Aug 2002
Posts: 371
Location: KTH, Centre for Speech Technology

PostPosted: Thu Nov 25, 2004 11:13 pm    Post subject: Reply with quote

This problem has been fixed in the upcoming release. Your file loads and plays nicely now (the content wasn't very interesting though icon_smile.gif ).

Next week...

Kåre
Back to top
View users profile Send private message Visit posters website
kare



Joined: 16 Aug 2002
Posts: 371
Location: KTH, Centre for Speech Technology

PostPosted: Wed Dec 01, 2004 6:08 pm    Post subject: Reply with quote

Try the latest release, hopfully the issue is resolved.

Kåre
Back to top
View users profile Send private message Visit posters website
Display posts from previous:   
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.1 © 2001, 2002 phpBB Group