©2003 Kåre Sjölander and Jonas Beskow
Introduction Download Documentation Links Forum
WaveSurfer user forum

FAQ  FAQ
Search  Search
Memberlist  Memberlist
Register  Register
Profile  Profile
Login  Login

RAW file configuration selection not opening/crash sotfware

 
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer
View previous topic :: View next topic  
Author Message
martial



Joined: 23 Nov 2004
Posts: 4

PostPosted: Tue Nov 23, 2004 2:09 am    Post subject: RAW file configuration selection not opening/crash sotfware Reply with quote

Hello,

I am using wavesurfer 1.7.4 and I encounter a strange issue when opening the file stored at:
[url]http://www.asliceof.net/tmp_files/22050_Lin32_Mono_Intel.raw[/url]

The file is: 22050Hz, Lin32, Mono, and Intel byte order and about 2 minutes longs.
This file is the exact audio content of the file listed in subject "Lin24Packed not handled properly" ([url]http://www1.speech.kth.se/prod/wavesurferforum/phpBB2/viewtopic.php?p=1014#1014[/url])
and was generated using a program writen to convert from 24b Motorola to 32b Intel.

When opening this file with waversurfer 1.7.4 (or even 1.5.4) I get the following error message before getting the "Interpret RAW file as" dialog box: "

[code]
Could not find MP3 header
while executing
"error $ret"
(procedure "wsurf::openFile" line 44)
invoked from within
"wsurf::openFile .x.s1 22050_Lin32_Mono_Intel.raw"
("eval" body line 1)
invoked from within
"eval wsurf::$cmd .x.s1 $args"
(procedure ".x.s1" line 1)
invoked from within
"$w openFile $fileName"
(procedure "OpenFile" line 23)
invoked from within
"OpenFile $file"
("foreach" body line 5)
invoked from within
"foreach file $surf(filelist) {
if {$surf(conf) != "unspecified"} {
OpenFile $file $surf(conf)
} else {
OpenFile $file
}
}"
invoked from within
"if {[llength $surf(filelist)] == 0} {
# no files given on command line, pack an empty widget
set w [wsurf .x.s[incr surf(count)] -messageproc setMs..."
(file "/mnt/data2/mk3test/wavesurfer/lib/app-wavesurfer-RELEASE/wavesurfer-RELEASE.tcl" line 2927)
invoked from within
"source /mnt/data2/mk3test/wavesurfer/lib/app-wavesurfer-RELEASE/wavesurfer-RELEASE.tcl"
("package ifneeded" script)
invoked from within
"package require app-wavesurfer-RELEASE"
(file "/mnt/data2/mk3test/wavesurfer/main.tcl" line 3)
[/code]

Interestingly this does not happen with version 1.5.1

Hope this helps,

-- Martial MICHEL[/code]
Back to top
View users profile Send private message
kare



Joined: 16 Aug 2002
Posts: 371
Location: KTH, Centre for Speech Technology

PostPosted: Tue Nov 23, 2004 3:25 pm    Post subject: Reply with quote

Very strange, I'll look into this one as well...

Kåre
Back to top
View users profile Send private message Visit posters website
Display posts from previous:   
Post new topic   Reply to topic    www.speech.kth.se/wavesurfer Forum Index -> WaveSurfer All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.1 © 2001, 2002 phpBB Group